summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-04-09 17:41:59 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-04-09 17:41:59 -0700
commit8ce50a587505b6aa03ad6cde8a958b0a0040073d (patch)
tree82f6c4434c36ccc3b2db614de43d5fa7c0a730f5 /Makefile.am
parentfbaa81a026aaaf8029487c4e960ef4b8bf58d055 (diff)
Use XORG_CWARNFLAGS instead of hardcoding -Wall in Makefile.am
Also switch changelog generation rule to XORG_CHANGELOG Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 93edbf3..c9c2ccd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
SUBDIRS = doc
-AM_CFLAGS = @XLIB_CFLAGS@ -Wall
+AM_CFLAGS = @XLIB_CFLAGS@ $(CWARNFLAGS)
sbin_PROGRAMS = mkcomposecache
EXTRA_DIST = ChangeLog mkallcomposecaches.sh
@@ -14,7 +14,7 @@ MAINTAINERCLEANFILES = Makefile.in configure aclocal.m4 config.h.in depcomp inst
.PHONY: ChangeLog
ChangeLog:
- (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+ $(CHANGELOG_CMD)
dist-hook: ChangeLog