summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2010-09-26 17:35:31 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2010-09-26 17:35:31 -0700
commited3908570e961d566ff13d8b38c2fa9efa2047ff (patch)
tree12a05a09337820485ca7641ee92f7419122a4d37 /configure.ac
parent0d7ea51f819d1e85909a3ec3fb637e3b4d703095 (diff)
config: Remove unnecessary calls from configure.ac
AC_PROG_CC & AC_PROG_INSTALL are provided by XORG_DEFAULT_OPTIONS now PKG_CONFIG_MODULES handles AC_SUBST of the CFLAGS & LIBS variables Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 1 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index abfd727..2954a79 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,8 +33,6 @@ XORG_DEFAULT_OPTIONS
AM_CONFIG_HEADER(config.h)
-AC_PROG_CC
-AC_PROG_INSTALL
AC_CANONICAL_HOST
@@ -73,6 +71,7 @@ case $host_os in
OS_CFLAGS=
;;
esac
+AC_SUBST(OS_CFLAGS)
AC_CHECK_HEADERS([pty.h stropts.h sys/ioctl.h sys/param.h sys/poll.h sys/select.h sys/time.h termios.h])
AC_CHECK_FUNCS([grantpt putenv select strdup])
@@ -93,10 +92,6 @@ fi
CF_FUNC_POLL
CF_SIGWINCH
-LUIT_CFLAGS="$LUIT_CFLAGS $OS_CFLAGS"
-AC_SUBST(LUIT_CFLAGS)
-AC_SUBST(LUIT_LIBS)
-
AC_CONFIG_FILES([Makefile
man/Makefile])