summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Kempczyński <zbigniew.kempczynski@intel.com>2023-03-20 18:39:27 +0100
committerZbigniew Kempczyński <zbigniew.kempczynski@intel.com>2023-03-20 18:49:51 +0100
commit03e6f46d06721863a98fd0866425151d535ed689 (patch)
treea962632e0874dcb60763aca62c28753a6b280236 /meson.build
parentf327c5d77b6ea6adff1ef6d08f21f232dfe093e3 (diff)
tests/xe/*: Revert and reapply patches to change Author tag
Revert "lib/xe_query: Rename for_each_* macros for Xe tests" This reverts commit 36a0eac3f4abc48beca0ee884db62936930ada68. Revert "text/xe/xe_exec_basic: Wait for the correct vm_bind before exec" This reverts commit aa07d3af0842853217f49e00b3be06e070b6cd75. Revert "tests/xe/xe_vm: Add a userptr-invalid test" This reverts commit 83adc6263867681e4349d3dfbfe6eb3d1353e07c. Revert "meson: replace "igt@xe/" by "igt@"" This reverts commit ba79234212730244429d318838b3f9474b929f56. Revert "xe_mmap: skip VRAM tests if no VRAM is found" This reverts commit 31e2c4875dfd909e22ce86bf1d0c055fb36f7966. Revert "xe/xe_*: add TEST/SUBTEST documentation" This reverts commit 99ef5a62a5dd6d8f9fe78962f7be2a8143fd8323. Revert "xe/xe_huc_copy: add GPU dependency to its documentation" This reverts commit dd8acc6da41c846d15405f877483514a18c0f97d. Revert "xe/xe_test_config.json: cleanup the field struct" This reverts commit 9ab205816f1bb3a2a5af38c0dc999662cd6b63c5. Revert "xe/xe_*: use correct MI_STORE_DWORD_IMM command length" This reverts commit 9c6205e35c4e6d364a179f290412cfb94cd80c93. Revert "tests/xe: Add Xe IGT tests" This reverts commit 54101d533656df5f908f7a1f10b01efbe89362c1. Signed-off-by: Zbigniew Kempczyński <zbigniew.kempczynski@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index cbb7ead7d..56875a219 100644
--- a/meson.build
+++ b/meson.build
@@ -261,6 +261,7 @@ libexecdir = join_paths(get_option('libexecdir'), 'igt-gpu-tools')
amdgpudir = join_paths(libexecdir, 'amdgpu')
v3ddir = join_paths(libexecdir, 'v3d')
vc4dir = join_paths(libexecdir, 'vc4')
+xedir = join_paths(libexecdir, 'xe')
mandir = get_option('mandir')
pkgconfigdir = join_paths(libdir, 'pkgconfig')
python3 = find_program('python3', required : true)
@@ -309,12 +310,18 @@ if get_option('use_rpath')
endforeach
vc4_rpathdir = join_paths(vc4_rpathdir, libdir)
+ xedir_rpathdir = '$ORIGIN'
+ foreach p : xedir.split('/')
+ xedir_rpathdir = join_paths(xedir_rpathdir, '..')
+ endforeach
+ xedir_rpathdir = join_paths(xedir_rpathdir, libdir)
else
bindir_rpathdir = ''
libexecdir_rpathdir = ''
amdgpudir_rpathdir = ''
v3d_rpathdir = ''
vc4_rpathdir = ''
+ xedir_rpathdir = ''
endif
subdir('lib')