summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:36:58 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:36:58 -0500
commit02e0bc6cebba093a382e0ab57ebe02e0c467b0d5 (patch)
tree8a474ec8715aa5bae10736dfce1121b351874c57 /Makefile.am
parent04305c486e81c275b7b31a505395a8279a9e4867 (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 84c8df7..bbb98a2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -61,3 +61,13 @@ SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog