summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index bdefeca..f7357e9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,6 +34,8 @@ bin_PROGRAMS = constype
constype_SOURCES = constype.c
+AM_CFLAGS = $(CWARNFLAGS)
+
appman_PRE = constype.man
appmandir = $(APP_MAN_DIR)
@@ -87,6 +89,6 @@ MAINTAINERCLEANFILES = ChangeLog
.PHONY: ChangeLog
ChangeLog:
- (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+ $(CHANGELOG_CMD)
dist-hook: ChangeLog