summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Vogt <mvo@ubuntu.com>2008-06-10 06:29:41 +0200
committerDanny Baumann <dannybaumann@web.de>2008-06-10 06:29:41 +0200
commitc2ccf359680cff11e136b7c93b874068ab8b2c02 (patch)
treef0380571064905855a65e0036d9be9c7585e08f6 /configure.ac
parent37afcb3d7fa588ab8013ee4956a377dc1de8e10b (diff)
Re-sync Metacity button parsing code with Metacity to support new "spacer" feature.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d04bca9a..fbbf560f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -326,6 +326,8 @@ if test "x$use_gtk" = "xyes"; then
[have_metacity_2_15_21=yes], [have_metacity_2_15_21=no])
PKG_CHECK_EXISTS(libmetacity-private >= 2.17.0,
[have_metacity_2_17_0=yes], [have_metacity_2_17_0=no])
+ PKG_CHECK_EXISTS(libmetacity-private >= 2.23.2,
+ [have_metacity_2_23_2=yes], [have_metacity_2_23_2=no])
fi
if test "x$use_gnome" = "xyes"; then
@@ -379,6 +381,10 @@ if test "$use_metacity" = yes; then
AC_DEFINE(HAVE_METACITY_2_17_0, 1,
[Define to 1 if metacity version >= 2.17.0])
fi
+ if test "$have_metacity_2_23_2" = yes; then
+ AC_DEFINE(HAVE_METACITY_2_23_2, 1,
+ [Define to 1 if metacity version >= 2.23.2])
+ fi
fi
AM_CONDITIONAL(USE_GNOME, test "x$use_gnome" = "xyes")