summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Reveman <davidr@novell.com>2007-08-02 17:05:55 -0400
committerDavid Reveman <davidr@novell.com>2007-08-02 17:05:55 -0400
commit6acb6a4b099f58fceef42fd546f80d5935e4ea8b (patch)
tree5b06a2c3a4cdb22758e6148d3a7e45282c328df6 /configure.ac
parentab0b6b5e47e7472ef9920fb2a89d1ee9f498760e (diff)
Add use of more compiler warnings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 42737220..5cdb94ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,6 +56,11 @@ if test "x$GCC" = "xyes"; then
*) CFLAGS="$CFLAGS -Wnested-externs" ;;
esac
+ case " $CFLAGS " in
+ *[[\ \ ]]-D_FORTIFY_SOURCE=2[[\ \ ]]*) ;;
+ *) CFLAGS="$CFLAGS -D_FORTIFY_SOURCE=2" ;;
+ esac
+
if test "x$enable_ansi" = "xyes"; then
case " $CFLAGS " in
*[[\ \ ]]-ansi[[\ \ ]]*) ;;
@@ -69,6 +74,18 @@ if test "x$GCC" = "xyes"; then
fi
fi
+if test "x$GCC" = "xyes"; then
+ case " $CXXFLAGS " in
+ *[[\ \ ]]-Wall[[\ \ ]]*) ;;
+ *) CXXFLAGS="$CXXFLAGS -Wall" ;;
+ esac
+
+ case " $CXXFLAGS " in
+ *[[\ \ ]]-D_FORTIFY_SOURCE=2[[\ \ ]]*) ;;
+ *) CXXFLAGS="$CXXFLAGS -D_FORTIFY_SOURCE=2" ;;
+ esac
+fi
+
AC_C_BIGENDIAN
plugindir=$libdir/compiz