summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Reveman <davidr@novell.com>2007-08-15 00:44:58 -0400
committerDavid Reveman <davidr@novell.com>2007-08-15 00:44:58 -0400
commit46892854d94c887dbb2e93b3b0223dfb442e054f (patch)
tree06d591ce948940770abec15955bbcab56a2c9dbf /configure.ac
parent9ece05ccdd5a6af850c090a852b9004f8f8e3aec (diff)
Install kcfg files and system-wide configuration file in
default kde directories.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 5c9fc3d4..e3f068a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -490,6 +490,8 @@ fi
if test "x$use_kconfig" = "xyes"; then
KCONFIG_CFLAGS=$KDE_CFLAGS
KCONFIG_LIBS=$KDE_LIBS
+ KDE_KCFG_DIR=`kde-config --install kcfg --expandvars 2>/dev/null`
+ KDE_KCONFIG_DIR=`kde-config --install config --expandvars 2>/dev/null`
fi
AM_CONDITIONAL(USE_KCONFIG, test "x$use_kconfig" = "xyes")
@@ -499,11 +501,7 @@ fi
AC_SUBST(KCONFIG_CFLAGS)
AC_SUBST(KCONFIG_LIBS)
-
-KDE_KCFG_DIR=$datadir/config.kcfg
AC_SUBST(KDE_KCFG_DIR)
-
-KDE_KCONFIG_DIR=$datadir/config
AC_SUBST(KDE_KCONFIG_DIR)
AC_ARG_WITH(max-desktops,