summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-23 18:10:35 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-23 18:10:35 +0000
commit78d7d8bac5b1f756c102d9052484663c57671e61 (patch)
treecf71a4e8963f3bafd3f5636a77f8d13a866c35a4 /Makefile.am
parent53adf02732a08a609757ec8ce633dc6ad2683c07 (diff)
Add build system for beforelight
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..f8793a4
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,31 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = beforelight
+
+beforelight_CFLAGS = $(DEP_CFLAGS)
+beforelight_LDADD = $(DEP_LIBS)
+
+beforelight_SOURCES = \
+ b4light.c
+
+man_MANS = \
+ b4light.man