summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9b71f5f..ef9a4cf 100644
--- a/meson.build
+++ b/meson.build
@@ -27,4 +27,12 @@ add_project_arguments(
language: 'c',
)
+cc = meson.get_compiler('c')
+
+have_cxx = add_languages('cpp', native: false, required: get_option('oss_fuzz').enabled())
+if have_cxx
+ cxx = meson.get_compiler('cpp')
+endif
+
subdir('src')
+subdir('fuzzing') \ No newline at end of file