summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2013-06-27 10:16:49 +0200
committerAlexander Larsson <alexl@redhat.com>2013-06-27 10:16:49 +0200
commitf251bd409e7f055dbc476c54a05da58b0caefbca (patch)
treeaad620eca41ba04dd6a9ccec279f3845123c2fcb /configure.ac
parent4595b819e4498a6d98ac1fb1f38662956fb31107 (diff)
Add manpages for all files and commands
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1120925..e3fc0bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,7 +64,20 @@ if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
else
AC_MSG_RESULT(no)
fi
-
+
+AC_ARG_ENABLE(documentation,
+ AC_HELP_STRING([--enable-documentation],
+ [build documentation]),,
+ enable_documentation=yes)
+if test x$enable_documentation = xyes; then
+ AC_PATH_PROG([XSLTPROC], [xsltproc])
+ if test x$XSLTPROC = x; then
+ AC_MSG_ERROR([xsltproc is required to build documentation])
+ fi
+fi
+AM_CONDITIONAL(BUILD_DOCUMENTATION, test x$enable_documentation = xyes)
+
AC_OUTPUT([ po/Makefile.in
Makefile
+man/Makefile
])