summaryrefslogtreecommitdiff
path: root/gnome/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gnome/src/Makefile.am')
-rw-r--r--gnome/src/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnome/src/Makefile.am b/gnome/src/Makefile.am
new file mode 100644
index 0000000..be9395d
--- /dev/null
+++ b/gnome/src/Makefile.am
@@ -0,0 +1,34 @@
+#
+# DBUS
+#
+
+BUILT_SOURCES = dapi-command-glue.h
+
+CLEANFILES = $(BUILT_SOURCES)
+
+%-glue.h: $(top_builddir)/data/%.xml
+ $(DBUSBINDINGTOOL) --mode=glib-server --output=$@ --prefix=$(subst -,_,$*) $^
+
+
+#
+# Daemon
+#
+INCLUDES = \
+ -I$(top_srcdir)/data \
+ -DDBUS_API_SUBJECT_TO_CHANGE \
+ $(DAPI_GNOME_CFLAGS)
+
+bin_PROGRAMS = dapi_gnome
+
+dapi_gnome_SOURCES = \
+ dapi-command.c \
+ dapi-command.h \
+ dapi-daemon.c \
+ dapi-debug.c \
+ dapi-debug.h \
+ dapi-gnome.c \
+ dapi-gnome.h
+
+dapi_gnome_LDADD = \
+ $(DAPI_GNOME_LIBS)
+