summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEamon Walsh <efw@eamonwalsh.com>2010-08-02 19:48:51 -0400
committerEamon Walsh <efw@eamonwalsh.com>2010-08-02 19:48:51 -0400
commite85cbb0e7a426aa99d116610eeef6af413f31d3f (patch)
tree1a3da35cc7b4c8c820496ff167f22121a6b67681 /configure.ac
parent42a60b714059e332705b1b5db2bc9ae0b1551aab (diff)
Miscellaneous autotools warning fixes.
Signed-off-by: Eamon Walsh <efw@eamonwalsh.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index bed3ee6..da345b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,8 +6,14 @@ AC_INIT([xpyb],
1.2,
[xcb@lists.freedesktop.org])
AC_CONFIG_SRCDIR([xpyb.pc.in])
-AM_INIT_AUTOMAKE([foreign dist-bzip2])
+AC_CONFIG_MACRO_DIR([m4])
+AC_DISABLE_STATIC
+AC_PROG_LIBTOOL
+AC_PROG_CC
+AC_CONFIG_HEADERS([src/config.h])
+
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_PATH_PYTHON([2.5])
AC_MSG_CHECKING([for python include dir])
PYTHON_INCLUDE=`$PYTHON -c "from distutils import sysconfig; \
@@ -20,12 +26,6 @@ fi
AC_MSG_RESULT([$PYTHON_INCLUDE])
AC_SUBST([PYTHON_INCLUDE])
-AC_CONFIG_HEADERS([src/config.h])
-
-AC_DISABLE_STATIC
-AC_PROG_LIBTOOL
-AC_PROG_CC
-
# Checks for pkg-config packages
PKG_CHECK_MODULES(XCBPROTO, xcb-proto >= 1.6)
PKG_CHECK_MODULES(LIBXCB, xcb > 1.5)