summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArnaud Fontaine <arnau@debian.org>2010-08-09 15:47:02 -0500
committerArnaud Fontaine <arnau@debian.org>2010-12-23 14:51:26 +0900
commit118a3c86b3d3b2fab20f365e4a5703e40ad2e1b1 (patch)
tree8d08d59638a6029304b933638c7e1e166f59eac3 /Makefile.am
parentd57825bee26d57625fe6629b44b33506894b9b6d (diff)
Create a single shared library and header file and reset SONAME
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2526855..50ea787 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,3 +3,19 @@ ACLOCAL_AMFLAGS = -I m4
MAINTAINERCLEANFILES = Makefile.in
SUBDIRS = atom aux event
+
+AM_CFLAGS = $(CWARNFLAGS)
+
+lib_LTLIBRARIES = libxcb-util.la
+
+libxcb_util_la_CPPFLAGS = $(XCB_CFLAGS)
+libxcb_util_la_LIBADD = $(XCB_LIBS)
+libxcb_util_la_LDFLAGS = -version-info 0:0:0
+libxcb_util_la_SOURCES = atom/atoms.c atom/atomlist.m4 atom/atoms.gperf.m4 \
+ atom/xcb_atom.h.m4 event/event.c aux/xcb_aux.c
+
+xcbinclude_HEADERS = xcb_util.h
+
+pkgconfig_DATA = xcb-util.pc
+
+EXTRA_DIST = xcb-util.pc.in