summaryrefslogtreecommitdiff
path: root/image/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'image/Makefile.am')
-rw-r--r--image/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/image/Makefile.am b/image/Makefile.am
index 1f7beed..f6a67ff 100644
--- a/image/Makefile.am
+++ b/image/Makefile.am
@@ -17,7 +17,11 @@ pkgconfig_DATA = xcb-image.pc
EXTRA_DIST=xcb-image.pc.in
-noinst_PROGRAMS = test_xcb_image test_xcb_image_shm test_formats test_bitmap
+noinst_PROGRAMS = test_xcb_image test_formats test_bitmap
+
+if HAVE_SHM
+noinst_PROGRAMS += test_xcb_image_shm
+endif
check_PROGRAMS = test_swap