summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJosh Triplett <josh@freedesktop.org>2006-02-18 16:49:41 -0800
committerJosh Triplett <josh@josh-mobile.localdomain>2006-02-18 16:49:41 -0800
commita49d7099e26ff026dfec35067908b18dc05d2e88 (patch)
tree3feac3cc85b79718d01ffc21f02b26ae4444ff0f /Makefile.am
Remove xcl and CVSROOT.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..6ba5c56
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,27 @@
+
+MAINTAINERCLEANFILES = Makefile.in
+
+SUBDIRS = tests
+
+EXTRA_DIST = autogen.sh README
+
+INCLUDES = $(XCB_CFLAGS)
+LDADD = $(XCB_LIBS)
+
+bin_PROGRAMS = hypnomoire xdpyinfo xcb-test dpms rendertest xcbrandr
+
+hypnomoire_LDADD = $(LDADD) $(XCBAUX_LIBS) -lm -lpthread
+hypnomoire_SOURCES = hypnomoire.c reply_formats.c
+
+xdpyinfo_SOURCES = xdpyinfo.c
+
+xcb_test_LDADD = $(LDADD) $(XCBAUX_LIBS) -lpthread
+xcb_test_SOURCES = main.c reply_formats.c
+
+dpms_SOURCES = dpms.c
+
+rendertest_LDADD = $(XCBAUX_LIBS)
+rendertest_SOURCES = rendertest.c
+
+xcbrandr_LDADD = $(XCBAUX_LIBS)
+xcbrandr_SOURCES = xcbrandr.c