summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChia-I Wu <olvaffe@gmail.com>2021-06-14 11:30:33 -0700
committerChia-I Wu <olvaffe@gmail.com>2021-07-01 11:55:48 -0700
commitd67cfcbd010d184d607df597e97fba1c4b213507 (patch)
tree7320a80b4a2c85765474628002c574f9a2aac255 /meson.build
parent49ca1883d40282a5abb631ea144c347b1b46777b (diff)
vkr: add a meson option to enable the validation layer
With -Dvenus-validation=true, vkr will enable the validation layer by setting ctx->validate_level = VKR_CONTEXT_VALIDATE_ON; ctx->validate_fatal = false; We would like to set ctx->validate_fatal to true, but even vulkaninfo has validation errors. We should create a list of VUIDs that are considered non-fatal before we can set ctx->validate_fatal to true. Signed-off-by: Chia-I Wu <olvaffe@gmail.com> Reviewed-by: Yiwei Zhang <zzyiwei@chromium.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2ccc20a..9c878bd 100644
--- a/meson.build
+++ b/meson.build
@@ -203,9 +203,14 @@ if with_glx
endif
with_venus = get_option('venus-experimental')
+with_venus_validate = get_option('venus-validate')
if with_venus
venus_dep = dependency('vulkan')
conf_data.set('ENABLE_VENUS', 1)
+
+ if with_venus_validate
+ conf_data.set('ENABLE_VENUS_VALIDATE', 1)
+ endif
endif
if cc.compiles('void __attribute__((hidden)) func() {}')