summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2023-01-18 17:17:59 +0400
committerMarc-André Lureau <marcandre.lureau@redhat.com>2023-02-13 11:16:22 +0400
commit3c492ffd253ce8dd162ddffb8f5104f595fce63b (patch)
tree2ad395e9cb9ea8097b11b62f32eabf9b100f9e32 /meson.build
parent961325ddab82f0c648ab5f30970ed61c1e256e0a (diff)
meson: use the more versatile get_variable()
As recommended since 0.51: https://mesonbuild.com/Release-notes-for-0-56-0.html#deprecate-dependencyget_pkgconfig_variable-and-dependencyget_configtool_variable Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Part-of: <https://gitlab.freedesktop.org/virgl/virglrenderer/-/merge_requests/1030>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index d69983f..73b8d94 100644
--- a/meson.build
+++ b/meson.build
@@ -212,7 +212,7 @@ else
endif
if with_egl
- if cc.has_header('epoxy/egl.h', dependencies: epoxy_dep) and epoxy_dep.get_pkgconfig_variable('epoxy_has_egl') == '1'
+ if cc.has_header('epoxy/egl.h', dependencies: epoxy_dep) and epoxy_dep.get_variable(pkgconfig: 'epoxy_has_egl') == '1'
gbm_dep = dependency('gbm', version: '>= ' + _gbm_ver, required: require_egl)
have_egl = gbm_dep.found()
if (have_egl)
@@ -225,7 +225,7 @@ if with_egl
endif
if with_glx
- if cc.has_header('epoxy/glx.h', dependencies: epoxy_dep) and epoxy_dep.get_pkgconfig_variable('epoxy_has_glx') == '1'
+ if cc.has_header('epoxy/glx.h', dependencies: epoxy_dep) and epoxy_dep.get_variable(pkgconfig: 'epoxy_has_glx') == '1'
glx_dep = dependency('x11', required: require_glx)
have_glx = glx_dep.found()
conf_data.set('HAVE_EPOXY_GLX_H', 1)