summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGwenole Beauchesne <gbeauchesne@splitted-desktop.com>2011-06-14 13:21:10 +0200
committerGwenole Beauchesne <gbeauchesne@splitted-desktop.com>2011-06-14 13:21:10 +0200
commit28e7d9ce0adc456e6d05884576a9b5eef7a484fa (patch)
tree6ad9c059450ff873e21c0265696419a36d19dc97 /Makefile.am
Import xvba-video 0.8.0 (GPLv2) sources.HEAD0.8.0master
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am57
1 files changed, 57 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..cd643f9
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,57 @@
+AUTOMAKE_OPTIONS = foreign
+
+SUBDIRS = debian.upstream src
+
+DOCS = \
+ AUTHORS \
+ COPYING \
+ NEWS \
+ README
+
+# Extra clean files so that maintainer-clean removes *everything*
+MAINTAINERCLEANFILES = \
+ aclocal.m4 compile config.guess config.sub \
+ configure depcomp install-sh ltmain.sh \
+ Makefile.in missing
+
+DEB_BUILDDIR = debian.build
+
+deb:
+ @[ -d debian ] || ln -s debian.upstream debian
+ dpkg-buildpackage -rfakeroot -uc -us
+
+deb.upstream: dist
+ -mkdir -p $(DEB_BUILDDIR)
+ cd $(DEB_BUILDDIR) && \
+ rm -rf $(PACKAGE)-$(VERSION) && \
+ tar zxvf ../$(PACKAGE)-$(VERSION).tar.gz && \
+ cd $(PACKAGE)-$(VERSION) && \
+ $(MAKE) deb -f Makefile.am
+
+bindistdir = $(distdir).$(TARGET_ARCH)
+
+bindist: bindist-gzip
+
+bindist_conf_flags =
+bindist_conf_flags += --enable-debug
+bindist_conf_flags += --enable-tracer
+
+bindistdir: dist-gzip
+ -rm -rf bindist-build; mkdir bindist-build
+ -cd bindist-build && tar zxf ../$(distdir).tar.gz
+ -cd bindist-build/$(distdir) && \
+ ./configure --prefix=/usr $(bindist_conf_flags) && \
+ $(MAKE)
+
+ -rm -rf $(bindistdir); mkdir $(bindistdir)
+ $(MAKE) install-strip \
+ DESTDIR=$(PWD)/$(bindistdir) \
+ -C bindist-build/$(distdir)
+ find $(bindistdir)/ -name "*.la" -exec rm -f {} \;
+ -rm -rf bindist-build
+
+ cp $(DOCS) $(bindistdir)/
+
+bindist-gzip: bindistdir
+ tar zcvf $(bindistdir).tar.gz $(bindistdir)
+ rm -rf $(bindistdir)