summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGwenole Beauchesne <gbeauchesne@splitted-desktop.com>2009-09-03 14:19:23 +0000
committerGwenole Beauchesne <gbeauchesne@splitted-desktop.com>2009-09-03 14:19:23 +0000
commitb9faae84a931c91441294aefecb9be7e2065a82d (patch)
tree9316f2dadef4e7839069836a3058d5271de20552 /configure.ac
parentfeada42a59386df657f5c2e2ed763f4b499dcd9c (diff)
Allow configuration options for DEBUG and TRACER.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 27 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index d50ef84..a7fcf34 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,10 +39,34 @@ AC_DEFINE([VDPAU_VIDEO_MICRO_VERSION], [vdpau_video_micro_version], [Micro versi
VDPAU_VIDEO_LT_LDFLAGS="-avoid-version"
AC_SUBST(VDPAU_VIDEO_LT_LDFLAGS)
+AC_DEFUN([AC_DEFINE_01], [
+ if test "$2" = "yes" -o "$2" = "guessing yes"; then
+ AC_DEFINE($1, 1, $3)
+ else
+ AC_DEFINE($1, 0, $3)
+ fi
+])
+
AC_ARG_ENABLE(glx,
- AC_HELP_STRING([--enable-glx],
- [enable OpenGL/X11 @<:@default=yes@:>@]),
- [], [enable_glx="yes"])
+ AC_HELP_STRING([--enable-glx],
+ [enable OpenGL/X11 @<:@default=yes@:>@]),
+ [], [enable_glx="yes"])
+
+AC_ARG_ENABLE(debug,
+ AC_HELP_STRING([--enable-debug],
+ [enable debugging information]),
+ [], [enable_debug="yes"])
+
+AC_DEFINE_01(USE_DEBUG, "$enable_debug",
+ [Enable debugging information])
+
+AC_ARG_ENABLE(tracer,
+ AC_HELP_STRING([--enable-tracer],
+ [enable VDPAU tracer]),
+ [], [enable_tracer="yes"])
+
+AC_DEFINE_01(USE_TRACER, "$enable_tracer",
+ [Enable VDPAU tracer])
AC_DISABLE_STATIC
AC_PROG_LIBTOOL