summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 17b2b2d..6c96cdd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,6 +68,12 @@ PKG_CHECK_MODULES(FREETYPE, freetype2, twin_ttf="yes", twin_ttf="no")
AC_SUBST(FREETYPE_LIBS)
AC_SUBST(FREETYPE_CFLAGS)
+# TWIN_DEP_*FLAGS define all flags required by dependencies of libtwin
+TWIN_DEP_LDFLAGS="$X_LIBS -lm"
+TWIN_DEPCFLAGS="$X_CFLAGS"
+AC_SUBST(TWIN_DEP_CFLAGS)
+AC_SUBST(TWIN_DEP_LDFLAGS)
+
AM_CONDITIONAL(TWIN_X11, test x$twin_x11 = xyes)
AM_CONDITIONAL(TWIN_FB, test x$twin_fb = xyes)
AM_CONDITIONAL(TWIN_TTF, test x$twin_ttf = xyes)