summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2012-03-23 15:05:23 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2012-03-26 12:14:14 +0100
commite5ff6de77fbd5e02e8db5a7fcd1576fdc98d6343 (patch)
treece622682b56a359255421269507bd204a6b553b8 /configure.ac
parentf67e56cc663593c0bb52f3e2a66970c81b8f77f3 (diff)
Avoid non-portable use of += in configure.ac
Similar to https://bugs.freedesktop.org/show_bug.cgi?id=46417 in Gabble. Reviewed-by: Jonny Lamb <jonny.lamb@collabora.co.uk> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=47774
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index baf73760..f345e8c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -320,15 +320,15 @@ prev_ac_configure_args=$ac_configure_args
ac_configure_args="$ac_configure_args --with-installed-headers=${wocky_install_headers_dir} --enable-shared-suffix=${PACKAGE}-${VERSION}"
if test "x$ENABLE_CODING_STYLE_CHECKS" = xyes ; then
- ac_configure_args+=" --enable-coding-style-checks"
+ ac_configure_args="$ac_configure_args --enable-coding-style-checks"
else
- ac_configure_args+=" --disable-coding-style-checks"
+ ac_configure_args="$ac_configure_args --disable-coding-style-checks"
fi
if test "x$tp_werror" = xyes && test "x$official_release" = xno; then
- ac_configure_args+=" --enable-Werror"
+ ac_configure_args="$ac_configure_args --enable-Werror"
else
- ac_configure_args+=" --disable-Werror"
+ ac_configure_args="$ac_configure_args --disable-Werror"
fi
prev_top_build_prefix=$ac_top_build_prefix