summaryrefslogtreecommitdiff
path: root/TelepathyQt/Farstream/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'TelepathyQt/Farstream/CMakeLists.txt')
-rw-r--r--TelepathyQt/Farstream/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/TelepathyQt/Farstream/CMakeLists.txt b/TelepathyQt/Farstream/CMakeLists.txt
index fe542967..18300fee 100644
--- a/TelepathyQt/Farstream/CMakeLists.txt
+++ b/TelepathyQt/Farstream/CMakeLists.txt
@@ -31,6 +31,7 @@ if(FARSTREAM_COMPONENTS_FOUND)
add_library(telepathy-qt${QT_VERSION_MAJOR}-farstream SHARED
${telepathy_qt_farstream_SRCS} ${telepathy_qt_farstream_MOC_SRCS})
endif ()
+ add_library(TelepathyQt${QT_VERSION_MAJOR}::Farstream ALIAS telepathy-qt${QT_VERSION_MAJOR}-farstream)
# We are building Telepathy-Qt-Farstream
target_compile_definitions(telepathy-qt${QT_VERSION_MAJOR}-farstream PRIVATE
@@ -54,6 +55,7 @@ if(FARSTREAM_COMPONENTS_FOUND)
# Set the correct version number
set_target_properties(telepathy-qt${QT_VERSION_MAJOR}-farstream PROPERTIES
+ EXPORT_NAME Farstream
SOVERSION ${TP_QT_ABI_VERSION}
VERSION ${TP_QT_LIBRARY_VERSION})