summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDario Freddi <dario.freddi@collabora.com>2012-01-30 15:38:26 +0100
committerAndre Moreira Magalhaes (andrunko) <andre.magalhaes@collabora.co.uk>2012-04-02 10:26:28 -0300
commit77cc2188ed70f1e15b5d21269f035c1507e97185 (patch)
treedf991955a90d60ec823122db17ba50e7b4871748 /CMakeLists.txt
parent1bf4422e80d7a817f7252c666a47488d9471692f (diff)
Add an option for enabling experimental service-side support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a8d93e13..2b6bb854 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -99,6 +99,13 @@ else (${TP_QT_NANO_VERSION} EQUAL 0)
set(TP_QT_LIBRARY_VERSION ${TP_QT_ABI_VERSION}.${TP_QT_MAJOR_VERSION}.${TP_QT_MINOR_VERSION}.${TP_QT_MICRO_VERSION}.${TP_QT_NANO_VERSION})
endif (${TP_QT_NANO_VERSION} EQUAL 0)
+# Add an option for compiling tp-qt-service
+option(ENABLE_EXPERIMENTAL_SERVICE_SUPPORT "Enable compilation of experimental and unstable service side bindings for Telepathy-Qt" FALSE)
+
+if (ENABLE_EXPERIMENTAL_SERVICE_SUPPORT)
+ message(STATUS "You have enabled experimental service support for Telepathy-Qt. Be aware there are no guarantees of API stability yet for service-side classes.")
+endif (ENABLE_EXPERIMENTAL_SERVICE_SUPPORT)
+
# The doxygen macro requires Qt to have been looked up to enable crosslinking
include(Doxygen)