summaryrefslogtreecommitdiff
path: root/TelepathyQt4Yell/Models/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'TelepathyQt4Yell/Models/CMakeLists.txt')
-rw-r--r--TelepathyQt4Yell/Models/CMakeLists.txt24
1 files changed, 0 insertions, 24 deletions
diff --git a/TelepathyQt4Yell/Models/CMakeLists.txt b/TelepathyQt4Yell/Models/CMakeLists.txt
index 140c444..4eb3629 100644
--- a/TelepathyQt4Yell/Models/CMakeLists.txt
+++ b/TelepathyQt4Yell/Models/CMakeLists.txt
@@ -6,61 +6,37 @@ add_definitions(-DBUILDING_TELEPATHY_QT4_YELL_MODELS)
# Set source files
set(telepathy_qt4_yell_models_SRCS
abstract-conversation-model.cpp
- accounts-model.cpp
- accounts-model-item.cpp
- avatar-image-provider.cpp
call-event-item.cpp
- contact-model-item.cpp
custom-event-item.cpp
event-item.cpp
- flat-model-proxy.cpp
session-conversation-model.cpp
text-event-item.cpp
- tree-node.cpp
)
set(telepathy_qt4_yell_models_MOC_SRCS
abstract-conversation-model.h
- accounts-model.h
- accounts-model-item.h
- avatar-image-provider.h
call-event-item.h
- contact-model-item.h
custom-event-item.h
event-item.h
- flat-model-proxy.h
session-conversation-model.h
text-event-item.h
- tree-node.h
)
set(telepathy_qt4_yell_models_HEADERS
AbstractConversationModel
- AccountsModel
- AccountsModelItem
- AvatarImageProvider
CallEventItem
- ContactModelItem
CustomEventItem
EventItem
- FlatModelProxy
Global
SessionConversationModel
TextEventItem
- TreeNode
abstract-conversation-model.h
- accounts-model.h
- accounts-model-item.h
- avatar-image-provider.h
call-event-item.h
- contact-model-item.h
custom-event-item.h
event-item.h
- flat-model-proxy.h
global.h
session-conversation-model.h
text-event-item.h
- tree-node.h
)
tpqt4_generate_mocs(${telepathy_qt4_yell_models_MOC_SRCS})