summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <george.kiagiadakis@collabora.co.uk>2011-02-18 17:47:05 +0200
committerGeorge Kiagiadakis <george.kiagiadakis@collabora.co.uk>2011-02-18 17:58:54 +0200
commit3ea55bd5c050e52334b6c9183f19616c9ba14b97 (patch)
tree491808cd2badab8c1c05b587b2c2f7e9ca51c32b /CMakeLists.txt
parent4f7072f3448664ddeba76ceb52bf1232b20d6d9c (diff)
Farstream: also require and link to telepathy-glib.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 72f6a50..7e9ede1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -163,13 +163,6 @@ macro_log_feature(GSTREAMER_FOUND "GStreamer"
"Needed, together with Tp-Farstream, to build telepathy-qt4-yell-farstream and some additional examples"
"http://www.gstreamer.net/" FALSE)
-# Build TelepathyQt4-Farstream only if GStreamer, TelepathyFarstream and all of their dependencies were found
-if (TELEPATHYFARSTREAM_FOUND AND GSTREAMER_FOUND AND GLIB2_FOUND AND GOBJECT_FOUND AND DBUS_FOUND AND LIBXML2_FOUND)
- set (FARSTREAM_COMPONENTS_FOUND 1)
-else (TELEPATHYFARSTREAM_FOUND AND GSTREAMER_FOUND AND GLIB2_FOUND AND GOBJECT_FOUND AND DBUS_FOUND AND LIBXML2_FOUND)
- set (FARSTREAM_COMPONENTS_FOUND 0)
-endif (TELEPATHYFARSTREAM_FOUND AND GSTREAMER_FOUND AND GLIB2_FOUND AND GOBJECT_FOUND AND DBUS_FOUND AND LIBXML2_FOUND)
-
# Find telepathy-glib
set(TELEPATHY_GLIB_MIN_VERSION 0.13.0)
find_package(TelepathyGlib)
@@ -178,6 +171,13 @@ macro_log_feature(TELEPATHYGLIB_FOUND "Telepathy-glib"
"http://telepathy.freedesktop.org/" FALSE "0.13.0"
"Needed, together with Qt Glib integration, to build most of the unit tests")
+# Build TelepathyQt4-Farstream only if GStreamer, TelepathyFarstream and all of their dependencies were found
+if (TELEPATHYFARSTREAM_FOUND AND TELEPATHYGLIB_FOUND AND GSTREAMER_FOUND AND GLIB2_FOUND AND GOBJECT_FOUND AND DBUS_FOUND AND LIBXML2_FOUND)
+ set (FARSTREAM_COMPONENTS_FOUND 1)
+else (TELEPATHYFARSTREAM_FOUND AND TELEPATHYGLIB_FOUND AND GSTREAMER_FOUND AND GLIB2_FOUND AND GOBJECT_FOUND AND DBUS_FOUND AND LIBXML2_FOUND)
+ set (FARSTREAM_COMPONENTS_FOUND 0)
+endif (TELEPATHYFARSTREAM_FOUND AND TELEPATHYGLIB_FOUND AND GSTREAMER_FOUND AND GLIB2_FOUND AND GOBJECT_FOUND AND DBUS_FOUND AND LIBXML2_FOUND)
+
# Enable glib-based tests only if Qt4 has GLib support and Telepathy-glib was found
if(QT4_GLIB_SUPPORT AND TELEPATHYGLIB_FOUND AND GLIB2_FOUND AND DBUS_FOUND)
set(ENABLE_TP_GLIB_TESTS 1)