summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWill Thompson <will.thompson@collabora.co.uk>2011-10-28 18:07:33 +0100
committerWill Thompson <will.thompson@collabora.co.uk>2011-10-28 18:09:14 +0100
commit634e6b5bc9a5a4cc6ffc29c1fa2869ae9c4f8701 (patch)
treead235908ca49c3adbe3e634f7b6f807321adc602 /configure.ac
parentf5e2025d90268a0a3c47a1f44b15e38c973652e9 (diff)
configure: explicitly depend on gio-2.0
Linkers from the future get upset, with messages like: /usr/bin/ld: ./.libs/libidle-convenience.a(idle-server-connection.o): undefined reference to symbol 'g_io_stream_get_output_stream' /usr/bin/ld: note: 'g_io_stream_get_output_stream' is defined in DSO /usr/lib/libgio-2.0.so.0 so try adding it to the linker command line /usr/lib/libgio-2.0.so.0: could not read symbols: Invalid operation So we need to explicitly depend on it. While we're here: we certainly don't build against glib 2.4. glib 2.28.0 is the version required by the version of telepathy-glib we require.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 25337b1..f075de1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,7 +71,7 @@ AC_HEADER_STDC([])
AC_C_INLINE
dnl Check for Glib
-PKG_CHECK_MODULES(GLIB, [glib-2.0 >= 2.4, gobject-2.0 >= 2.4])
+PKG_CHECK_MODULES(GLIB, [glib-2.0 >= 2.28.0, gobject-2.0 >= 2.28.0, gio-2.0 >= 2.28.0 ])
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)