summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Pitt <martin.pitt@ubuntu.com>2015-06-18 08:42:15 +0200
committerMartin Pitt <martin.pitt@ubuntu.com>2015-06-18 09:51:37 +0200
commit65d21ff344cb7013447e14cdcd83cf43b72fd6f8 (patch)
tree3c2ecd6b06f532305befaec11dd94053df8724d8 /Makefile.am
parent4584eaea927c182ba403420701944022a222a29b (diff)
build-sys: don't dist man/systemd.directives.xml
It depends on man/custom-entities.ent which is (and needs to be) a built file, so we need to always build man/systemd.directives.xml as well. We also need to drop this from update-man-list so that it doesn't get disted from Makefile-man.am. Fixes distcheck failure. https://github.com/systemd/systemd/issues/215
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index ba7f79b9c..532d5eeb8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -700,11 +700,10 @@ noinst_DATA += \
CLEANFILES += \
man/index.html
-XML_GLOB = $(wildcard $(top_srcdir)/man/*.xml $(top_builddir)/man/*.xml)
NON_INDEX_XML_FILES = $(filter-out man/systemd.index.xml,$(XML_FILES))
SOURCE_XML_FILES = ${patsubst %,$(top_srcdir)/%,$(filter-out man/systemd.directives.xml,$(NON_INDEX_XML_FILES))}
-update-man-list: $(top_srcdir)/tools/make-man-rules.py $(XML_GLOB)
+update-man-list: $(top_srcdir)/tools/make-man-rules.py $(SOURCE_XML_FILES)
$(AM_V_GEN)$(PYTHON) $^ > $(top_srcdir)/Makefile-man.tmp
$(AM_V_at)mv $(top_srcdir)/Makefile-man.tmp $(top_srcdir)/Makefile-man.am
@echo "Makefile-man.am has been regenerated"
@@ -726,7 +725,7 @@ endif
endif
EXTRA_DIST += \
- $(XML_FILES) \
+ $(filter-out man/systemd.directives.xml,$(XML_FILES)) \
$(HTML_FILES) \
$(HTML_ALIAS) \
$(man_MANS) \
@@ -735,7 +734,6 @@ EXTRA_DIST += \
tools/xml_helper.py \
man/systemd.index.xml \
man/index.html \
- man/systemd.directives.xml \
man/glib-event-glue.c \
$(NULL)