summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMilan Bouchet-Valat <nalimilan@club.fr>2009-08-17 13:15:15 +0200
committerMilan Bouchet-Valat <nalimilan@club.fr>2009-08-18 23:15:37 +0200
commit44a0d8ab8e6cc286132fa30ac5cfff481e573bdd (patch)
tree3c48250a204e3e61dfdc8d41353e10a32566978c /configure.in
parentf12409d939bd4d7634131cb985a4704b034f25e9 (diff)
Port to PolicyKit1
We can remove many parts of the code thanks to the new version. This is fully incompatible with previous API of PolicyKit, so clients need to be updated too. This patch uses D-Bus connexion to identify the client, which does not work for now with PolkitLockButton in the GUI. Next patch fixes that, but could possibly be reverted or simplified later.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 49e537f..864a5e1 100644
--- a/configure.in
+++ b/configure.in
@@ -12,7 +12,7 @@ IT_PROG_INTLTOOL([0.40.0])
DBUS_REQUIRED=1.1.2
DBUS_GLIB_REQUIRED=0.74
GLIB_REQUIRED=2.4.0
-POLICYKIT_REQUIRED=0.5
+POLICYKIT_REQUIRED=0.92
GIO_REQUIRED=2.15.2
dnl get prefix in $prefix, yes, this sucks
@@ -66,7 +66,7 @@ DBUS_SERVICES_DIR="${prefix}/share/dbus-1/system-services"
AC_SUBST(DBUS_SERVICES_DIR)
dnl PolicyKit policy files dir
-POLKIT_POLICY_DIR="${prefix}/share/PolicyKit/policy/"
+POLKIT_POLICY_DIR="${datadir}/polkit-1/actions/"
AC_SUBST(POLKIT_POLICY_DIR)
dnl where is DBus system.d directory?
@@ -123,7 +123,7 @@ AC_SUBST(DISPATCHER_LIBS)
AC_SUBST(DISPATCHER_CFLAGS)
dnl check for PolicyKit
-PKG_CHECK_MODULES(POLKIT, polkit-dbus >= $POLICYKIT_REQUIRED, have_polkit=yes, have_polkit=no)
+PKG_CHECK_MODULES(POLKIT, polkit-gobject-1 >= $POLICYKIT_REQUIRED, have_polkit=yes, have_polkit=no)
if test "$have_polkit" = "yes"; then
AC_DEFINE(HAVE_POLKIT, [1], [whether PolicyKit was found])