summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Janků <jjanku@redhat.com>2020-07-03 18:30:08 +0200
committerFrediano Ziglio <freddy77@gmail.com>2020-07-31 12:48:28 +0100
commit630da73bf869a69b906b1d3e0aa1f6d00c9c632d (patch)
tree27b52c858adf3802d778bd10890938f303aabf47 /Makefile.am
parent6fea9f59a760cbc1655de0d11a8abfa6567ae951 (diff)
clipboard: enable copying files from client using webdav
When the user wants to copy files, new spice-gtk can share those files using the existing phodav server. In that case, it advertises the VD_AGENT_CLIPBOARD_FILE_LIST type in the clipboard grab message. Upon request of the clipboard data in the mentioned type, spice-gtk provides a list of absolute paths in the phodav server - these are the files that are supposed to be copied/moved. The role of the vdagent is to adjust this data given the drive letter of the mapped webdav share. Files can be both copied and moved, although move was tested only with Windows' File Explorer. Copying files from the vdagnet side to the client is not supported yet. Signed-off-by: Jakub Janků <jjanku@redhat.com> Acked-by: Frediano Ziglio <fziglio@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6e464c7..425b052 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,7 @@ endif
bin_PROGRAMS = vdagent vdservice
-vdagent_LDADD = $(LIBPNG_LIBS) $(ZLIB_LIBS) -lwtsapi32 -lgdi32 -luuid -lole32 -loleaut32 vdagent_rc.$(OBJEXT)
+vdagent_LDADD = $(LIBPNG_LIBS) $(ZLIB_LIBS) -lwtsapi32 -lgdi32 -luuid -lole32 -loleaut32 -lmpr -lshlwapi vdagent_rc.$(OBJEXT)
vdagent_CXXFLAGS = $(AM_CXXFLAGS) $(LIBPNG_CFLAGS)
vdagent_LDFLAGS = $(AM_LDFLAGS) -Wl,--subsystem,windows
vdagent_SOURCES = \