summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2012-10-30 22:01:55 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2012-10-31 10:11:47 +0100
commit23c87a26b1d2657546f4a52e41c7a0421526bbfc (patch)
treef1e8fda9c573d47aa18378731175564124d8cf04 /Makefile.am
parentf485c777272954a8b406d1faec1dd26e88121e63 (diff)
build-sys: Use git-version-gen
This gives much better version numbers when using git snapshots.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fcfe3af..b050aff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -61,6 +61,7 @@ MAINTAINERCLEANFILES += vdservice_rc.$(OBJEXT)
EXTRA_DIST = \
+ $(top_srcdir)/.version \
tests/clipboard.py \
vdagent.sln \
vdagent/resource.h \
@@ -70,5 +71,14 @@ EXTRA_DIST = \
vdservice/vdservice.rc \
vdservice/vdservice.vcproj
+# see git-version-gen
+dist-hook:
+ echo $(VERSION) > $(distdir)/.tarball-version
+
+BUILT_SOURCES = $(top_srcdir)/.version
+$(top_srcdir)/.version:
+ echo $(VERSION) > $@-t && mv $@-t $@
+
+
-include $(top_srcdir)/git.mk