summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorFrediano Ziglio <fziglio@redhat.com>2020-03-09 09:03:46 +0000
committerFrediano Ziglio <fziglio@redhat.com>2020-03-12 18:57:08 +0000
commitac38d4bbf94655014b003f1c746b13f9b5df8e74 (patch)
tree31c8aff7521bea1a79bc1c19e037c5527e9fb2cd /meson.build
parent7a4ca27f98002f34b0be8810265a09cc4dc08f29 (diff)
build: By default use debugoptimized build type for Meson
Usually the default options for C are "-O2 -g". So this build type is more conservative. Normal users wanting to build the package won't find themselves with a bad performance executable. This will catch some potentially warning not detected with debug build. Signed-off-by: Frediano Ziglio <fziglio@redhat.com> Acked-by: Eduardo Lima (Etrunko) <etrunko@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 7cad72e5..bb99e4f0 100644
--- a/meson.build
+++ b/meson.build
@@ -4,7 +4,8 @@
project('spice', 'c',
version : run_command('build-aux/git-version-gen', meson.source_root() + '/.tarball-version', check : true).stdout().strip(),
license : 'LGPLv2.1',
- meson_version : '>= 0.48')
+ meson_version : '>= 0.48',
+ default_options : ['buildtype=debugoptimized'])
message('Updating submodules')
run_command('build-aux/meson/check-spice-common', check : true)