summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrediano Ziglio <fziglio@redhat.com>2017-05-19 12:21:48 +0100
committerFrediano Ziglio <fziglio@redhat.com>2017-08-30 15:59:46 +0100
commit14aee7cd745cbb6d2f3d5203dbb878dbe966dbc5 (patch)
treecdbd5459290d2b9948f2280f405b4181817aa87e /configure.ac
parent20676792a8222c9499c79be8cac39341a03b3a3c (diff)
gstreamer: Check if ORC library can work
ORC library is used internally by GStreamer to generate code dynamically. If ORC cannot allocate executable memory, the failure causes an abort(3) to be called. This happens on some SELinux configurations that disable executable memory allocation (execmem boolean). Check that ORC could work before attempting to use GStreamer to avoid crashes. While this check is done, the ORC library outputs an error which will be well visible in Qemu output. Signed-off-by: Frediano Ziglio <fziglio@redhat.com> Acked-by: Christophe Fergeau <cfergeau@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a840eebd..f80193b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -116,6 +116,12 @@ AS_IF([test x"$missing_gstreamer_elements" = xyes],
[SPICE_WARNING([The GStreamer video encoder can be built but may not work.])
])
+if test "x$have_gstreamer_0_10" = "xyes" -o "x$have_gstreamer_1_0" = "xyes"; then
+ PKG_CHECK_MODULES(ORC, orc-0.4)
+ AC_SUBST(ORC_CFLAGS)
+ AC_SUBST(ORC_LIBS)
+fi
+
AC_ARG_ENABLE([automated_tests],
AS_HELP_STRING([--enable-automated-tests], [Enable automated tests using spicy-screenshot (part of spice-gtk)]),,
[enable_automated_tests="no"])