summaryrefslogtreecommitdiff
path: root/meson_options.txt
diff options
context:
space:
mode:
authorFrediano Ziglio <fziglio@redhat.com>2018-12-11 22:19:45 +0000
committerFrediano Ziglio <fziglio@redhat.com>2019-01-23 14:44:19 +0000
commit2e914f3305f685c82143fa04067ce9f57fbfd602 (patch)
tree566ec6fc47884e3a0b7698ce3b94cf96afb81672 /meson_options.txt
parent0a753b93b50b548a2ac04023c96a7cda83f204bf (diff)
Integrate recorder library
Allow to use recorder library. See https://github.com/c3d/recorder for details. The main usage will be to collect statistics while the programs will run. By default the recorder will be disabled at compile time. The idea of the usage in SPICE is to collect data while the program run. Using current SPICE logging facility was discussed but not easy to filter data. Other solutions (SystemTap, LTTng) were discarded due to not cross platform. A printf based solution was discussed too but missing the additional tools which are useful. Currently we don't plan to use as extensively as to be a problem to be replaced or removed in the future. Both Autoconf and Meson build systems are supported. Autoconf requires the addition of SPICE_CHECK_RECORDER call in configure.ac. Meson requires to add recorder option. Signed-off-by: Frediano Ziglio <fziglio@redhat.com> Acked-by: Victor Toso <victortoso@redhat.com>
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson_options.txt b/meson_options.txt
index 1b80257..a90726a 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -20,6 +20,12 @@ option('opus',
yield : true,
description: 'Enable Opus audio codec')
+option('recorder',
+ type : 'boolean',
+ value : false,
+ yield : true,
+ description: 'Enable recorder instrumentation')
+
option('smartcard',
type : 'boolean',
value : true,