summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJakub Jelen <jakuje@gmail.com>2019-12-15 21:33:24 +0100
committerFrediano Ziglio <freddy77@gmail.com>2020-04-17 16:29:34 +0100
commit57deaec6d70711c1cb87896991ab1fe9ff1879b3 (patch)
tree31765494c974de6f9ff64d3001dc14de23b2b57c /meson.build
parent358e2d8bb045d80803190534ec1986c4242d10fc (diff)
Add first simple fuzzer
Per [1], we are good to go to integrate in oss-fuzz. This adds aa simple fuzzer and some housekeeping/preparatory work around build system to be able to build fuzzers for oss-fuzz. The fuzzers can be built only with new meson build system as trying to make it working with autotools was quite a pain. The oss-fuzz is already running on my fork temporarily, before this will be merged as in [2]. [1] https://github.com/google/oss-fuzz/pull/3019 [2] https://github.com/google/oss-fuzz/pull/3466 Signed-off-by: Jakub Jelen <jjelen@redhat.com> Acked-by: Frediano Ziglio <fziglio@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index d5b85a9..9cfe248 100644
--- a/meson.build
+++ b/meson.build
@@ -1,4 +1,4 @@
-project('libcacard', 'c',
+project('libcacard', 'c', 'cpp',
version: run_command('build-aux/git-version-gen', '@0@/.tarball-version'.format(meson.source_root()), check: true).stdout().strip(),
license: 'LGPLv2.1',
default_options: ['warning_level=2'],
@@ -7,6 +7,7 @@ project('libcacard', 'c',
meson.add_dist_script('build-aux/meson-dist', meson.project_version(), meson.source_root())
cc = meson.get_compiler('c')
+cxx = meson.get_compiler('cpp')
static_dep = (get_option('default_library') == 'static')
@@ -96,3 +97,4 @@ pc.generate(
if not get_option('disable_tests')
subdir('tests')
endif
+subdir('fuzz')