summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2019-11-28 18:51:30 +0100
committerSumit Bose <sbose@redhat.com>2019-11-28 18:51:30 +0100
commit506887297ea33339d8ad8b274be643d220bf22f8 (patch)
tree94d0a1c58bac1dba0461d210b8cf98c379e42b6e /configure.ac
parent81b5e3478269ea47d66ddb98f7cbebd06fe950e6 (diff)
configure: do not inherit DISTRO from the environment
The argument of the --with-distro configure option is stored in the variable DISTRO. If DISTRO is already set in the build environment it should not be used hence DISTRO must be cleared by the configure script if not set by --with-distro. Related to https://bugzilla.redhat.com/show_bug.cgi?id=1638396
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e335247..a424a49 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,7 +31,8 @@ AC_ARG_WITH([distro],
[AS_HELP_STRING([--with-distro],
[Configure for a specific distribution (eg: redhat)]
)],
- [DISTRO=$withval])
+ [DISTRO=$withval],
+ [DISTRO=])
if test -z $DISTRO; then
AC_CHECK_FILE(/etc/redhat-release, [DISTRO="redhat"])