summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarius Vollmer <mvollmer@redhat.com>2013-03-20 19:56:00 +0200
committerStef Walter <stefw@gnome.org>2013-03-22 15:16:30 +0100
commit0c67bd00d78ca450e951912e6034be28755cb371 (patch)
treec7e0c6fd0cb74b10f9f1d16cff9e9351f6fcc770 /configure.ac
parentd1455dddb2763cd13c2ebb0c52c500b1b73da48e (diff)
Optionally use systemd's journal for logging.
And include a REALMD_OPERATION field if doing so. https://bugs.freedesktop.org/show_bug.cgi?id=62225
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 81a38da..f25caac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,6 +82,23 @@ PKG_CHECK_MODULES(POLKIT, polkit-gobject-1)
AC_SUBST(POLKIT_CFLAGS)
AC_SUBST(POLKIT_LIBS)
+# --------------------------------------------------------------------
+# systemd journal
+
+AC_ARG_WITH(journal,
+ AC_HELP_STRING([--with-systemd-journal],
+ [Use systemd's journal for logging]),
+ [],
+ [with_systemd_journal=no])
+
+if test "$with_journal" != "no"; then
+ AC_DEFINE_UNQUOTED(WITH_JOURNAL, 1, [Use systemd's journal])
+ PKG_CHECK_MODULES(SYSTEMD_JOURNAL, libsystemd-journal)
+ with_journal="yes"
+fi
+AC_SUBST(SYSTEMD_JOURNAL_CFLAGS)
+AC_SUBST(SYSTEMD_JOURNAL_LIBS)
+
# -------------------------------------------------------------------
# Kerberos
@@ -336,3 +353,6 @@ echo " Coverage: $enable_coverage"
echo " Strict: $enable_strict"
echo " Documentation: $enable_doc"
echo
+echo "OPTIONAL DEPENDENCIES:"
+echo " Journal: $with_journal"
+echo