summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2019-08-02 12:10:43 +0200
committerSumit Bose <sbose@redhat.com>2019-08-02 13:20:36 +0200
commit5ae42c176e7bb550fc6cf10f29e75f58c733ae4f (patch)
tree6be74a035a70e3a359052ba2a4b414724bb5711f /Makefile.am
parent4d7dc5fd266c3a8177ac413b98c7778cc769ed56 (diff)
Remove support for deprecated gtester format
Support for the already deprecated gtester format was remove from recent versions of glib2 but the test still call the tab-gtester conversion tool. This patch removes tab-gtester and the tab format is used directly. Related to https://gitlab.freedesktop.org/realmd/realmd/issues/21
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 27e3494..4ffd5b4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -161,7 +161,7 @@ endif
#
LOG_DRIVER = $(top_srcdir)/build/tap-driver
-LOG_COMPILER = $(top_srcdir)/build/tap-gtester
+LOG_COMPILER = sh -c '"$$0" "$$@" --tap'
VALGRIND_ARGS = --trace-children=no --quiet --error-exitcode=33 \
--suppressions=valgrind-suppressions --gen-suppressions=all \
@@ -183,7 +183,6 @@ recheck-memory: valgrind-suppressions
EXTRA_DIST += \
$(LOG_DRIVER) \
- $(LOG_COMPILER) \
$(VALGRIND_SUPPRESSIONS) \
$(NULL)