summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2012-05-09 21:15:50 +0200
committerStef Walter <stefw@gnome.org>2012-05-09 21:30:21 +0200
commit64b1f6b692f9a69433c7458f8bc09bcae80c8821 (patch)
tree90d959baaaab35ff5f82cf2f363843676ca984cc /Makefile.am
Initial commit
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..737d96d
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,47 @@
+
+SUBDIRS = \
+ library \
+ doc \
+ po
+
+ACLOCAL_AMFLAGS = -I m4
+
+DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-gtk-doc \
+ --disable-coverage
+
+dist-hook:
+ @if test -d "$(srcdir)/.git"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generate automatically. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run git log --stat --date=short ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || ( rm -f ChangeLog.tmp ; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo A git clone is required to generate a ChangeLog >&2; \
+ fi
+
+if WITH_COVERAGE
+coverage:
+ mkdir -p tests/coverage
+ $(LCOV) --directory . --zerocounters
+ $(MAKE) check
+ $(LCOV) --directory . --capture --output-file tests/coverage.info
+ $(GENHTML) --output-directory tests/coverage tests/coverage.info
+ @echo "file://$(abs_top_builddir)/tests/coverage/index.html"
+endif
+
+if ENABLE_GTK_DOC
+upload-doc: all
+ rsync -Hvax --exclude doc \
+ doc/html/./ anarchy.freedesktop.org:/srv/my-path/www/doc/libadcli/./
+endif
+
+upload-release: $(DIST_ARCHIVES)
+ gpg --detach-sign --local-user 'stef@thewalter.net' $(DIST_ARCHIVES)
+ scp $(DIST_ARCHIVES) $(DIST_ARCHIVES).sig anarchy.freedesktop.org:/srv/my-path/www/releases/
+
+EXTRA_DIST = config.rpath