summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2023-05-26 00:33:13 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2023-05-26 03:16:38 +0530
commit4125ace620e0799fc7930fe90198d7ba02ae22fd (patch)
tree47c6f87d2750c4d60c4afd24bc493cf1b0fa029d /meson.build
parentaa32d179d099b6ca7aaa3133fa362c55c1e1d0ba (diff)
meson: Fix compatibility with Fedora's abseil-cpp package
1. Fedora abseil-cpp package is built with C++17: https://src.fedoraproject.org/rpms/abseil-cpp/blob/rawhide/f/abseil-cpp.spec 2. There is no `absl_types` pkgconfig file, and it's only needed on iOS
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index fb06073..057bcd9 100644
--- a/meson.build
+++ b/meson.build
@@ -4,7 +4,7 @@ project('webrtc-audio-processing', 'c', 'cpp',
default_options : [ 'warning_level=1',
'buildtype=debugoptimized',
'c_std=c11',
- 'cpp_std=c++14',
+ 'cpp_std=c++17',
]
)
@@ -57,7 +57,6 @@ have_win = false
absl_dep = [
dependency('absl_base'),
dependency('absl_flags'),
- dependency('absl_types'),
dependency('absl_strings'),
dependency('absl_synchronization'),
]
@@ -66,6 +65,8 @@ if ['darwin', 'ios'].contains(host_system)
os_cflags = ['-DWEBRTC_MAC']
if host_system == 'ios'
os_cflags += ['-DWEBRTC_IOS']
+ # For absl_bad_optional_access
+ absl_dep += [dependency('absl_types')]
endif
have_posix = true
elif host_system == 'android'