summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGeorg Chini <georg@chini.tk>2020-01-15 20:34:30 +0100
committerPulseAudio Marge Bot <pulseaudio-maintainers@lists.freedesktop.org>2021-11-03 21:13:38 +0000
commit6f162031444ef330a2d47b65a5699d5d1caa6512 (patch)
treeefdb679f32d3d35942d9eb16b90dcccc8858659b /meson.build
parent156b572954d87363cc050687be9e77a384b89479 (diff)
Add configuration option enable-smoother-2 to enable alternative smoother code
Part-of: <https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/55>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ae0c66310..d2864bc80 100644
--- a/meson.build
+++ b/meson.build
@@ -615,6 +615,10 @@ if get_option('running-from-build-tree')
cdata.set('HAVE_RUNNING_FROM_BUILD_TREE', 1)
endif
+if get_option('enable-smoother-2')
+ cdata.set('USE_SMOOTHER_2', 1)
+endif
+
alsa_dep = dependency('alsa', version : '>= 1.0.24', required : get_option('alsa'))
if alsa_dep.found()
cdata.set('HAVE_ALSA', 1)