summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGreg V <greg@unrelenting.technology>2020-04-03 18:51:59 +0300
committerPulseAudio Marge Bot <pulseaudio-maintainers@lists.freedesktop.org>2021-01-18 16:33:52 +0000
commit4ff664a3eb7542826f56cf941b7e9d5c080ceffc (patch)
tree440ef44655a894ed6f4ae6a290f81d94939e5647 /meson.build
parent42a92548912817162e20992582851a94bea56f62 (diff)
build-sys: meson: when libc iconv is used, tell libiconv header to pretend to be libc's iconv
The libiconv header on FreeBSD would be preferred by include path, but we don't want to link to libiconv, so tell its header to act like the system header. Part-of: <https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/277>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 38d56bafb..51ef84486 100644
--- a/meson.build
+++ b/meson.build
@@ -439,6 +439,8 @@ have_iconv = false
if cc.has_function('iconv_open')
iconv_dep = dependency('', required : false)
have_iconv = true
+ # tell the libiconv header to pretend to be libc iconv
+ cdata.set('LIBICONV_PLUG', 1)
else
iconv_dep = cc.find_library('iconv', required : false)
have_iconv = iconv_dep.found()