summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2023-11-29 09:46:50 +0000
committerJan Rybar <jrybar@redhat.com>2023-11-29 09:46:50 +0000
commit24f1e0af3f7bd17e220cb96201f3c654e737ad34 (patch)
treeead452a40f89f339a056ef454376f841d248df12 /meson.build
parent4a441db99d5c4bee13b3a86a4ae78c12c023cf50 (diff)
Add sysusers file
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e86f87e..23d5f28 100644
--- a/meson.build
+++ b/meson.build
@@ -218,6 +218,8 @@ if enable_logind
# FIXME: systemd.pc file does not use variables with relative paths, so `define_variable` cannot be used
systemd_systemdsystemunitdir = systemd_dep.get_pkgconfig_variable('systemdsystemunitdir')
endif
+
+ systemd_sysusers_dir = systemd_dep.get_pkgconfig_variable('sysusers_dir', default: '/usr/lib/sysusers.d')
endif
config_h.set('HAVE_LIBSYSTEMD', enable_logind)
@@ -227,6 +229,9 @@ config_h.set('HAVE_PIDFD_OPEN', cc.get_define('SYS_pidfd_open', prefix: '#includ
polkitd_user = get_option('polkitd_user')
config_h.set_quoted('POLKITD_USER', polkitd_user)
+polkitd_uid = get_option('polkitd_uid')
+config_h.set('POLKITD_UID', polkitd_uid)
+
# Select which authentication framework to use
auth_deps = []
@@ -403,6 +408,9 @@ if enable_logind
output += ' systemdsystemunitdir: ' + systemd_systemdsystemunitdir + '\n'
endif
output += ' polkitd user: ' + polkitd_user + ' \n'
+if polkitd_uid != '-'
+ output += ' polkitd UID: ' + polkitd_uid + ' \n'
+endif
output += ' Javascript engine: ' + js_engine + '\n'
output += ' PAM support: ' + enable_pam.to_string() + '\n\n'
if libs_only