summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 95cc6f7c3..25b12a7c1 100644
--- a/meson.build
+++ b/meson.build
@@ -24,10 +24,16 @@ libsystemd = []
if get_option('systemd')
libsystemd = dependency('libsystemd', version: '>=213')
systemd_system_unit_dir = get_option('systemdsystemunitdir')
- if systemd_system_unit_dir == ''
+ systemd_user_unit_dir = get_option('systemduserunitdir')
+ if systemd_system_unit_dir == '' or systemd_user_unit_dir == ''
systemd = dependency('systemd')
+ endif
+ if systemd_system_unit_dir == ''
systemd_system_unit_dir = systemd.get_pkgconfig_variable('systemdsystemunitdir')
endif
+ if systemd_user_unit_dir == ''
+ systemd_user_unit_dir = systemd.get_pkgconfig_variable('systemduserunitdir')
+ endif
add_project_arguments ('-DHAVE_SYSTEMD_SD_LOGIN_H=1', language: 'c')
else