summaryrefslogtreecommitdiff
path: root/gui/Updater/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gui/Updater/CMakeLists.txt')
-rw-r--r--gui/Updater/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/gui/Updater/CMakeLists.txt b/gui/Updater/CMakeLists.txt
index 47a05c4..9545a9a 100644
--- a/gui/Updater/CMakeLists.txt
+++ b/gui/Updater/CMakeLists.txt
@@ -4,12 +4,15 @@ set(kpk_update_SRCS
PkAddRm_Model.cpp
PkAddRm_Delegate.cpp
pkg_item.cpp
+ ../Common/PkTransaction.cpp
+ ../Common/PkStrings.cpp
)
kde4_add_ui_files(kpk_update_SRCS
PkUpdate.ui
+ ../Common/PkTransaction.ui
)
kde4_add_plugin(kcm_kpk_update ${kpk_update_SRCS})
-target_link_libraries(kcm_kpk_update ${KDE4_KDEUI_LIBS} ${KDE4_KPARTS_LIBS} ${KDE4_KNEWSTUFF2_LIBS} packagekit-qt)
+target_link_libraries(kcm_kpk_update ${KDE4_KDEUI_LIBS} ${QPACKAGEKIT_LIB})
-install(TARGETS kcm_kpk_update DESTINATION ${PLUGIN_INSTALL_DIR} ) \ No newline at end of file
+install(TARGETS kcm_kpk_update DESTINATION ${PLUGIN_INSTALL_DIR} )