summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Skeggs <bskeggs@redhat.com>2014-06-19 14:54:20 +1000
committerBen Skeggs <bskeggs@redhat.com>2014-06-19 15:57:35 +1000
commit86024ceef015ffe31a204cc5bc6c326a19363ff1 (patch)
treeb9463ea3dab5f6d98ecab8604526d715bd3371c8 /configure.ac
parentfd0ce8839f307693d86c7602dd926ce79e6b777d (diff)
glamor: initial support (no dri)
Signed-off-by: Ben Skeggs <bskeggs@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c524660..c34e575 100644
--- a/configure.ac
+++ b/configure.ac
@@ -127,6 +127,15 @@ AC_SUBST([DRIVER_NAME])
XORG_MANPAGE_SECTIONS
XORG_RELEASE_VERSION
+AC_MSG_CHECKING([whether to include GLAMOR support])
+if pkg-config --exists "xorg-server >= 1.15.99.901"
+then
+ AC_DEFINE(HAVE_GLAMOR, 1, [Build support for glamor acceleration])
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+
AC_CONFIG_FILES([
Makefile
src/Makefile