summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcin Slusarz <marcin.slusarz@gmail.com>2014-06-22 01:31:46 +0200
committerBen Skeggs <bskeggs@redhat.com>2014-06-24 19:21:38 +1000
commit41c1c4ee867753422d6486f13bf20b45905a5dd5 (patch)
treecc712cff372dc654e15745ea7f0feb4e1e7377aa /configure.ac
parentf0fa8313714c2a5b16e784b257b5ff79da3a443b (diff)
glamor: fix build without glamor.h
xorg-server can be built without glamor, which leads to: CC nouveau_xv.lo In file included from nouveau_xv.c:41:0: nouveau_glamor.h:12:20: fatal error: glamor.h: No such file or directory compilation terminated. Signed-off-by: Marcin Slusarz <marcin.slusarz@gmail.com> Signed-off-by: Ben Skeggs <bskeggs@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c34e575..92e047a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -128,7 +128,13 @@ XORG_MANPAGE_SECTIONS
XORG_RELEASE_VERSION
AC_MSG_CHECKING([whether to include GLAMOR support])
-if pkg-config --exists "xorg-server >= 1.15.99.901"
+
+AC_COMPILE_IFELSE(AC_LANG_PROGRAM(
+[[
+ #include <glamor.h>
+]],[[]]),[found_glamor_header=yes],[found_glamor_header=no])
+
+if test "$found_glamor_header" = "yes" && pkg-config --exists "xorg-server >= 1.15.99.901"
then
AC_DEFINE(HAVE_GLAMOR, 1, [Build support for glamor acceleration])
AC_MSG_RESULT([yes])