summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPierre-Eric Pelloux-Prayer <pierre-eric.pelloux-prayer@amd.com>2024-01-26 15:09:18 +0100
committerPierre-Eric Pelloux-Prayer <pierre-eric.pelloux-prayer@amd.com>2024-02-01 09:28:41 +0100
commitd9f15f8d9ba5f920b77132e5b688f1f08cf8db04 (patch)
treeb33fd05e4d29ae306443c018917c0c6b7fdfcd6c /meson.build
parente4f7754977f4c2380a66223818391cc1e128227f (diff)
meson: require libelf when radeonsi is built
radeonsi has a hard dependency on libelf so tell meson about this requirement. Closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/10240 Reviewed-by: Marek Olšák <marek.olsak@amd.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/27295>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 28c723410e1..1d7439d9c63 100644
--- a/meson.build
+++ b/meson.build
@@ -1884,6 +1884,8 @@ if not with_platform_windows and not dep_elf.found()
endif
if dep_elf.found()
pre_args += '-DUSE_LIBELF'
+elif with_gallium_radeonsi
+ error('Gallium driver radeonsi requires libelf')
endif
dep_glvnd = null_dep