summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTomeu Vizoso <tomeu.vizoso@collabora.com>2023-09-06 18:26:37 +0200
committerMarge Bot <emma+marge@anholt.net>2024-01-24 10:02:10 +0000
commitaf199e0ff01250313bad5fde2905cfb796fb1930 (patch)
treedf2c63283984789dde2cf5d0ed10a0e5885a0e88 /meson.build
parent92904108706f979cd80cee57af58d866e0f9f7ba (diff)
teflon: Initial commit
Teflon is a Gallium frontend that TensorFlow Lite can load to delegate the execution of operations in a neural network model. See docs for more. Acked-by: Christian Gmeiner <cgmeiner@igalia.com> Acked-by: Dave Airlie <airlied@redhat.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/25714>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6d10219f067..a8d84c00b20 100644
--- a/meson.build
+++ b/meson.build
@@ -2144,6 +2144,13 @@ if with_perfetto
pre_args += '-DHAVE_PERFETTO'
endif
+with_teflon = get_option('teflon')
+if with_teflon and with_tests
+ dep_xtensor = dependency('xtensor')
+ dep_flatbuffers = dependency('flatbuffers')
+ prog_flatc = find_program('flatc')
+endif
+
with_gpuvis = get_option('gpuvis')
if with_gpuvis
pre_args += '-DHAVE_GPUVIS'
@@ -2362,3 +2369,6 @@ if with_perfetto and with_any_datasource
perfetto_summary += {'Data source': with_datasources}
endif
summary(perfetto_summary, section: 'Perfetto', bool_yn: true, list_sep: ' ')
+
+teflon_summary = {'Enabled': with_teflon}
+summary(teflon_summary, section: 'Teflon (TensorFlow Lite delegate)', bool_yn: true, list_sep: ' ')