summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSebastian Wick <sebastian.wick@redhat.com>2022-09-01 00:59:52 +0200
committerMarge Bot <emma+marge@anholt.net>2024-02-27 13:10:13 +0000
commita00f9c401bbe7c537fde2dbf277e0790a52b7052 (patch)
tree791843d1e5496c2fd1eea7cb95e2a032bdada2bd /meson.build
parentdf801bec1e6cd58d1a21e955cac5026dd5914f7a (diff)
loader/wayland: Add fallback wl_display_dispatch_queue_timeout
This is almost a 1:1 copy of the same function in libwayland. If the version with the symbol propagates far enough the fallback can be removed again. Signed-off-by: Sebastian Wick <sebastian.wick@redhat.com> Reviewed-by: Daniel Stone <daniels@collabora.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/27511>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 90d2f3644fa..c551bad452e 100644
--- a/meson.build
+++ b/meson.build
@@ -2014,6 +2014,12 @@ if with_platform_wayland
dep_wayland_egl_headers = dep_wayland_egl.partial_dependency(compile_args : true)
endif
pre_args += '-DWL_HIDE_DEPRECATED'
+ if cc.has_function(
+ 'wl_display_dispatch_queue_timeout',
+ prefix : '#include <wayland-client.h>',
+ dependencies: dep_wayland_client)
+ pre_args += ['-DHAVE_WL_DISPATCH_QUEUE_TIMEOUT']
+ endif
endif
dep_x11 = null_dep